请求高手把这个【精准买卖】指标公式改为条件选股公式,成功率蛮高的,而且无未来函数。(能改进更好)

2024-05-26

1. 请求高手把这个【精准买卖】指标公式改为条件选股公式,成功率蛮高的,而且无未来函数。(能改进更好)

这个就是简单地MACD选股啊,中间那几个划线一删就是了:
DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIFF,9);
MACD:=(DIFF-DEA)*2;
买入:CROSS(DIFF,DEA);
卖出:CROSS(DEA,DIFF);

请求高手把这个【精准买卖】指标公式改为条件选股公式,成功率蛮高的,而且无未来函数。(能改进更好)

2. 请高手把这个公式改成通达信选股公式,选出当天出现的【黑马起爆点】信号的股票,急需,谢谢!!!


3. 求高手把以下公式修改成无未来函数的公式,且提高准确率.谢谢!

XG:(ZIG(3,6)>=REF(ZIG(3,6),1))AND(REF(ZIG(3,6),1)<=REF(ZIG(3,6),2))AND(REF(ZIG(3,6),2)<=REF(ZIG(3,6),3))AND(REF(ZIG(3,6),3)<=REF(ZIG(3,6),4));(友情提示:含未来函数ZIG,无甚意义的公式!)

求高手把以下公式修改成无未来函数的公式,且提高准确率.谢谢!

4. 这个通达信公式高手看看如何,能否改成条件选股公式,如果能去掉未来函数最好多谢了

N:=7;
A1:=REF(H,N)=HHV(H,2*N+1); 
B1:=FILTER(A1,N); 
C1:=BACKSET(B1,N+1); 
D1:=FILTER(C1,N);{高点}
A2:=REF(L,N)=LLV(L,2*N+1); 
B2:=FILTER(A2,N);
C2:=BACKSET(B2,N+1); 
D2:=FILTER(C2,N);{低点}
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2; E2:=(H+L)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(C)=1;
L1:=(D2 AND NOT(D1 AND E1=E2);
X1:=REF(BARSLAST(H1),1)+1; 
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1); 
I1:=BACKSET(G1,2); 
LD:=I1>REF(I1,1);{过滤后低点}
L2:=LD OR ISLASTBAR OR BARSCOUNT(C)=1;
X2:=REF(BARSLAST(L2),1)+1; 
F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);{过滤后高点}
R1:=BACKSET(ISLASTBAR,BARSLAST(HD)+1); S1:=R1>REF(R1,1); {前一高}
T1:=BACKSET(ISLASTBAR,BARSLAST(LD)+1); U1:=T1>REF(T1,1); {前一低}
R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); S2:=R2>REF(R2,1); {前二高}
T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2); U2:=T2>REF(T2,1); {前二低}
T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2); U3:=T3>REF(T3,1); {前三低}
T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2); U4:=T4>REF(T4,1); {前四低}
R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); S3:=R3>REF(R3,1); {前三高}
R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2); S4:=R4>REF(R4,1); {前四高}
XG: U1 OR U2 OR U3 OR U4;

点评:
这个公式的核心价值就是未来函数。去掉的话,就没有意义了。
这个主图公式主要是用来观察趋势,而不是用来决定买卖点的。

5. 求高手将通达信的指标公式改成选股公式

{低位金叉}
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26); 
DEA:=EMA(DIFF,9); 
低位金叉:CROSS(DIFF,DEA) AND DIFF<-0.1;
 
{二次金叉}
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26); 
DEA:=EMA(DIFF,9);
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0)); 
二次金叉:CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,34)=1;
 
{底背离}
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26); 
DEA:=EMA(DIFF,9);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1)); 
底背离:REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
 
股票公式专家团为你解答,希望能帮到你,祝投资顺利。
如果你对我的解答感到满意,请别忘了采纳,谢谢。

求高手将通达信的指标公式改成选股公式

6. 求高手帮忙把以下指标公式改成选股公式

注意公式有未来函数
VAR3:=LLV(HIGH,240);
VAR4:=100*(CLOSE-VAR3)/VAR3;
VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
VARA:=BARSCOUNT(CLOSE);
VARB:=VAR835;
VARC:=VARB AND COUNT(VARB,1)=1;
VARD:=EMA(CLOSE,21)-EMA(CLOSE,8);
VARE:=EMA(VARD,5);
VARF:=TROUGHBARS(3,6,1)<4 AND CROSS(VARD,VARE);
VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
VAR12:=ZIG(3,6)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
VAR14:=ZIG(3,22)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
VAR16:=ZIG(3,51)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
VAR18:=ZIG(3,72)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR1A:=EMA(VAR19,100);
VAR1B:=2*(VAR19-VAR1A);
VAR1C:=POW(VAR1B,3)*0.1+POW(VAR1B,1);
VAR1D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
VAR1E:=EMA(VAR1D*0.97,3);
VAR1F:=(HIGH+LOW+CLOSE)/3;
VAR20:=(VAR1F-MA(VAR1F,14))/(0.015*AVEDEV(VAR1F,14));
VAR21:=CROSS(VAR1E,LOW);
选股买点:VAR10;

7. 请高手帮忙把这个通达信里的指标公式改成选股公式,万分感谢啊!

这个公式很准,但有未来函数。选股公式如下:
VAR1:=(C+H+O+L)/4;
卖出:=XMA(VAR1,N)*(1+P1/1000),COLORGREEN,LINETHICK2;
买入:=XMA(VAR1,M)*(1-P2/1000),COLORMAGENTA,LINETHICK2;
CROSS(LOW,买入);
其中XMA是标准的未来函数,也就是信号会发生漂移。因此这个公式只能用来做参考,且莫用做股票操作的依据。

请高手帮忙把这个通达信里的指标公式改成选股公式,万分感谢啊!

8. 谁能把下面的公式改成选股公式,选出起爆点大于30的股票,谢谢了

起爆点:=(DCLOSE-REF(CLOSE,9))/REF(CLOSE,9)*100;
起爆:CROSS(起爆点,30);
 
(不过:不定周期收盘价DCLOSE  信号会漂移)